Thursday, November 16, 2017

POINT TO POINT AUTHENTICATION PROTOCOL



AIM : To perform Point to Point Authentication (PAP and CHAP) Protocol functions between the Routers and Computers in the network.

PROCEDURE
1)    Create a topology using 2 Routers for PAP Protocol
2)    Create a topology using 2 Routers for CHAP Protocol
3)    Configure IP address to routers go to global configuration mode in R0 and R1configure connected interfaces
4)    Assign IP address for interfaces
5)    Configure both routers with PAP / CHAP Protocol
6)    Use the Ping Command to verify the connectivity
 

PAP PROTOCOL – TOPOLOGY CONFIGURATION





ROUTER 0
Router> enable
Router# configure terminal
Router(config)# username trichy password 123
Router(config)# exit
Router# show ip interface brief
Router# configure terminal

Router(config)# interface fastethernet 0/0
Router(config-if)# ip address 10.0.0.1 255.0.0.0
Router(config-if)# no shutdown
Router(config-if)# exit

Router(config)# interface serial 0/1/0
Router(config-if)# encapsulation ppp
Router(config-if)# ip address 20.0.0.1 255.0.0.0
Router(config-if)# no shutdown

Router(config-if)# router eigrp 100
Router(config-router)# network 10.0.0.0
Router(config-router)# network 20.0.0.0
Router(config-router)# exit
Router(config)# interface serial 0/1/0
Router(config-if)# ppp pap sent-username chennai password abc
Router(config-if)# ppp authentication pap
Router(config-if)# exit
Router(config)# exit

ROUTER 1
Router> enable
Router# configure terminal
Router(config)# username chennai password abc
Router(config)# interface serial 0/1/0
Router(config-if)# ip address 30.0.0.1 255.0.0.0
Router(config-if)# no shutdown
Router(config)# interface serial 0/1/0
Router(config-if)# encapsulation ppp
Router(config-if)# ip address 20.0.0.2 255.0.0.0
Router(config-if)# no shutdown

Router(config-if)# router eigrp 100
Router(config-router)# network 20.0.0.0
Router(config-router)# network 30.0.0.0
Router(config-router)# exit
Router(config)# interface serial 0/1/0
Router(config-if)# ppp pap sent-username trichy password 123
Router(config-if)# ppp authentication pap
Router(config-if)# exit
Router(config)# exit

Router 0
Router# debug ppp authentication
PPP authentication debugging is on
Router# configure terminal
Router(config)# interface serial 0/1/0
Router(config-if)# sh
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# exit
Router#

ROUTER 1
Router# debug ppp authentication
PPP authentication debugging is on
Router# configure terminal
Router(config)# interface serial 0/1/0
Router(config-if)# sh
Router(config-if)# no shutdown
Router(config-if)# exit

CHAP PROTOCOL – TOPOLOGY CONFIGURATION
 

ROUTER 0
enable
configure Terminal
interface fastethernet 0/0
ip address 10.0.0.1 255.0.0.0
no shutdown
interface serial 0/1/0
encapsulation ppp
ip address 20.0.0.1 255.0.0.0
no shutdown
router rip
network 10.0.0.0
network 20.0.0.0

ROUTER 1
enable
configure Terminal
interface fastethernet 0/0
ip address 30.0.0.1 255.0.0.0
no shutdown
interface serial 0/1/0
encapsulation ppp
ip address 20.0.0.2 255.0.0.0
no shutdown
router rip
network 20.0.0.0
network 30.0.0.0




ROUTER 0
configure terminal
username rb password 123
interface serial 0/1/0
ppp authentication chap

ROUTER 1
configure terminal
username ra password 123
interface serial 0/1/0
ppp authentication chap

ROUTER 0 and 1
debug ppp authentication

ROUTER 0 and 1
interface serial 0/1/0
shutdown
no shutdown

No comments:

Post a Comment

Note: Only a member of this blog may post a comment.